Bug#560052: ardour-i686: Ardour with debian-patches crashes while performing audio-analysis

Klaumi Klingsporn klaumikli at gmx.de
Tue Dec 8 15:59:40 UTC 2009

Package: ardour-i686
Version: 1:2.8.4-1
Severity: normal

The following bug is reproducable here with the official ardour-package and with a local ardourvst-package with debian-patches, but not with a local non-patched version of ardour 2.8.4.

=> 1. scenario:

Open ardour and create a new session. In the menu set "Options/Misc Options/Auto-analyze new audio" to true. Try to import some audio as new region. A convert-audio-window appears and after 100% are reached ardour crashes (core dumped) with the message in console:

"Vamp::HostExt::PluginLoader: Unable to load library "/usr/lib/ardour2/vamp/libardourvampplugins.so": /usr/lib/ardour2/vamp/libardourvampplugins.so: undefined symbol: _ZTIN11_VampPlugin4Vamp17PluginAdapterBaseE

glibmm-ERROR **: 
unhandled exception (type std::exception) in signal handler:
what: failed constructor

subgraph starting at ardour timed out (subgraph_wait_fd=12, status = 0, state = Triggered, pollret = 0 revents = 0x0)

**** alsa_pcm: xrun of at least 1.018 msecs

subgraph starting at ardour lost client
bad status (-2) for client ardour handling event (type = 8)
jack main caught signal 12

**** alsa_pcm: xrun of at least 862.547 msecs

Abgebrochen (Speicherabzug geschrieben)"

The analysis-subdirectory of the session remains empty.

=> 2. scenario:
Open ardour and create a new session; check that "Options/Misc Options/Auto-analyze new audio" is set to false; import some audio. Than set "Options/Misc Options/Auto-analyze new audio" to true and save the session. Than try to import some new audio as region, which will fail as described above in scenario 1. But in this case the session-file contains the line
    <Option name="auto-analyse-audio" value="1"/>
which causes ardour to analyze the not yet analysed first imported audio while opening the session - and ardour will crash. The only possibility to open the session with debian-ardour is to remove the above line from the session-file or set the value to "0". A non-debian-patched ardour opens the file without problems and performs the requested audio-analyis. 
On the other hand: After the analysis is performed and there are according files in the sessions subdirctory analysis are created the debian-patched ardour works fine, even fft-analysis of a range. 

Because of the error-message above i think there is a problem with the vamp-patch or the debian-vamp-sdk - but I'm only a user ;-)

Thanks for maintaining ardour for debian!


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-2-686-preempt (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages ardour-i686 depends on:
ii  jackd                    0.118+svn3796-1 JACK Audio Connection Kit (server 
ii  libart-2.0-2             2.3.20-2        Library of functions for 2D graphi
ii  libasound2               1.0.21a-1       shared library for ALSA applicatio
ii  libatk1.0-0              1.28.0-1        The ATK accessibility toolkit
ii  libaubio2                0.3.2-4         a library for audio segmentation
ii  libc6                    2.10.2-2        GNU C Library: Shared libraries
ii  libcairo2                1.8.8-2         The Cairo 2D vector graphics libra
ii  libcairomm-1.0-1         1.8.0-1         C++ wrappers for Cairo (shared lib
ii  libcurl3-gnutls          7.19.7-1        Multi-protocol file transfer libra
ii  libfftw3-3               3.2.2-1         library for computing Fast Fourier
ii  libfontconfig1           2.6.0-4         generic font configuration library
ii  libfreetype6             2.3.11-1        FreeType 2 font engine, shared lib
ii  libgcc1                  1:4.4.2-3       GCC support library
ii  libglib2.0-0             2.22.3-1        The GLib library of C routines
ii  libglibmm-2.4-1c2a       2.22.1-2        C++ wrapper for the GLib toolkit (
ii  libgnomecanvas2-0        2.26.0-1        A powerful object-oriented display
ii  libgnomecanvasmm-2.6-1c2 2.26.0-1        C++ wrappers for libgnomecanvas2 (
ii  libgtk2.0-0              2.18.3-1        The GTK+ graphical user interface 
ii  libgtkmm-2.4-1c2a        1:2.18.2-1      C++ wrappers for GTK+ 2.4 (shared 
ii  libjack0                 0.118+svn3796-1 JACK Audio Connection Kit (librari
ii  liblo0ldbl               0.23-2.2        Lightweight OSC library
ii  liblrdf0                 0.4.0-1.2       a library to manipulate RDF files 
ii  libpango1.0-0            1.26.1-1        Layout and rendering of internatio
ii  libpangomm-1.4-1         2.26.0-1        C++ Wrapper for pango (shared libr
ii  libraptor1               1.4.19-1        Raptor RDF parser and serializer l
ii  librasqal1               0.9.16-1        Rasqal RDF query library
ii  librdf0                  1.0.9-2+b1      Redland Resource Description Frame
ii  libsamplerate0           0.1.7-3         Audio sample rate conversion libra
ii  libsigc++-2.0-0c2a       2.0.18-2        type-safe Signal Framework for C++
ii  libslv2-9                0.6.6-2         A library for simple use of LV2 pl
ii  libsndfile1              1.0.20-3        Library for reading/writing audio 
ii  libstdc++6               4.4.2-3         The GNU Standard C++ Library v3
ii  libvamp-hostsdk2         1.3-1           helper library for Vamp hosts writ
ii  libvamp-sdk1             1.3-1           helper library for Vamp plugins wr
hi  libxml2                  2.7.6.dfsg-1    GNOME XML library
ii  libxslt1.1               1.1.26-1        XSLT processing library - runtime 
ii  python                   2.5.4-2         An interactive high-level object-o
ii  python-gtk2              2.16.0-1        Python bindings for the GTK+ widge
ii  python-twisted           8.2.0-3         Event-based framework for internet

Versions of packages ardour-i686 recommends:
ii  dillo [www-browser]       2.1.1-0+dillo1 small and fast web browser
ii  iceweasel [www-browser]   3.5.5-1        lightweight web browser based on M
ii  kazehakase [www-browser]  0.5.8-1        GTK+-based web browser that allows
ii  konqueror [www-browser]   4:4.3.2-1      KDE 4's advanced file manager, web
ii  links [www-browser]       2.2-1+b1       Web browser running in text mode
ii  lynx-cur [www-browser]    2.8.8dev.1-1   Text-mode WWW Browser with NLS sup
ii  netsurf-gtk [www-browser] 2.1-2          Small portable web browser with CS
ii  w3m [www-browser]         0.5.2-2.1      WWW browsable pager with excellent

Versions of packages ardour-i686 suggests:
ii  jamin                        0.95.0-4+b1 Audio mastering from a mixed down 
ii  qjackctl                     0.3.4-1     User interface for controlling the

-- no debconf information

More information about the pkg-multimedia-maintainers mailing list