Bug#476384: Please port to new libmpcdec API

Reinhard Tartler siretart at tauware.de
Sat Mar 21 10:39:47 UTC 2009

Reimar Döffinger <Reimar.Doeffinger at gmx.de> writes:

> On Sat, Mar 21, 2009 at 08:57:04AM +0100, Sebastian Dröge wrote:
>> libmpc will be uploaded to unstable in the next days. Please port your
>> package to the new API ASAP, it will most probably fail to build after
>> the upload to unstable.
> If MPlayer fails to build, configure should be updated to just disable
> libmpc support. libavcodec is (and should be) used for decoding in
> current MPlayer, libmpc is only still supported because MPlayer used a
> different internal bitstream format that some people may accidentially
> have saved e.g. into AVI files.

May I take that as "libmpc support is deprecated nowadays" in mplayer?
In that case I'll remove that configure switch in a minute in our
mplayer git packaging branch.

Reinhard Tartler, KeyID 945348A4

More information about the pkg-multimedia-maintainers mailing list