Bug#370599: Maintaining opencore-amr packages

Martin Storsjö martin at martin.st
Fri May 15 08:23:09 UTC 2009

On Thu, 14 May 2009, Andres Mejia wrote:

> On Thursday 14 May 2009 05:19:51 Martin Storsjö wrote:
> > One of the main things to do would be to rename the actual libs, I think,
> > so it doesn't conflict with the old libamr; that'd ease development on a
> > machine when transitioning from one version to another. That'd require
> > some minor patches to ffmpeg to make it able to use a similar library with
> > a new name. Or if the interfaces would be made binary compatible (by
> > prefixing e.g. the Decoder_Interface_Decode symbol with GP3 as in the old
> > libamr), it perhaps could be made a fullblown drop-in replacement - I'm
> > not too familiar with all the details in debian packaging in how to
> > accomplish that cleanly, though, so it doesn't break installation of old
> > packages depending on libamr.
> I would like this to be a drop in replacement for at least the libamr-nb library 
> and the libamr-wb decoder.

Ok, then you probably just want to rename the symbols. My wrapper just 
implements the default version, which is named GP3- in the old libamr.

// Martin

More information about the pkg-multimedia-maintainers mailing list