Bug#552137: No sound in-/output on OSS

Klaus Ethgen Klaus at Ethgen.de
Fri Oct 23 20:03:46 UTC 2009

Hash: SHA512


Am Fr den 23. Okt 2009 um 18:24 schrieb Adrian Knoth:
> > OSS output is complete broken.
> According to <http://wiki.debian.org/ReleaseGoals/NoLinuxDevDsp>, an
> appropriate way of fixing this bug is to drop OSS support in audacity
> completely.

That is the first I hear now and it is, sorry, completely inacceptable.
That would end to not having sound at all!

I run linux for decades now and I did never have big problems with oss.
Unfortunately Linus start to drop them complete from the kernel so I
have to use the commercial stuff (Which is now free too).

I gave alsa many tests now and I was never able to bring them to work.
The code is instable so that the kernel ops in under 5 minutes and the
sound quality is very broken (if it work at all) so that a simple
movement of the mouse jerking the sound.

However, I have no problem if other people want to use such a ...
software. But I have to stick on OSS if I want sound in future.

So this decision would end in one more debian package I have to compile
myself. The last few years (since sarge or so) I notice that Debian
seams to get more and more worse and more and more software end in a
instable and unusable state where the fix is sometimes pretty simple.

Please kick that decision to trash and continue supporting stable
platform and technology.

> be added to toplevel's configure script around line 9223:
>    ac_configure_args="$ac_configure_args --without-oss"
> Or patch lib-src/portaudio/configure:2062 from "yes" to "no".

Hmm... So the bug is in portaudio. So more worse as portaudio comes to
bring a legacy layer over all possible sound systems.

- -- 
Klaus Ethgen                            http://www.ethgen.de/
pub  2048R/D1A4EDE5 2000-02-26 Klaus Ethgen <Klaus at Ethgen.de>
Fingerprint: D7 67 71 C4 99 A6 D4 FE  EA 40 30 57 3C 88 26 2B
Version: GnuPG v1.4.9 (GNU/Linux)


More information about the pkg-multimedia-maintainers mailing list