gmerlin-avdecoder redux

IOhannes m zmoelnig zmoelnig at
Mon Aug 16 07:55:12 UTC 2010

On 2010-08-16 07:12, Hans-Christoph Steiner wrote:

>> and of course the debian/copyright has to be updated; hans?
> Wow, its not pretty in the land of copyright statements.  There are more
> files with the bad BSD license:
> lib/base64.c
> lib/os.c
> include/bgav_sem.h

see jonas' and my mails on this topic under the subject "Licensing of
gmerlin-avdecoder regression tests"

> Also, I left out copyright statements on these files since I understand
> that we are not going to use them:
> lib/GSM610
> lib/libw32dll

that's ok, but:
are you working on the latest and greatest git?
jonas has done a nice job with the repackaging and copyright detection:
first of all the lib/GSM610/ and lib/libw32dll/ are no longer there, so
you don't even need to ignore them :-)
even more nicely, you get copyright information on all files during the
buildpackage process, and which files have problematic licenses.

> Another little detail, I recall that gmerlin-avdecoder 1.0.3 depends on
> a certain version on gavl, I believe that's 1.1.1 or 1.1.2.  Also, I

well, the latest released gmerlin-avdecoder is 1.0.3 (2010-02-27), which
is what we are trying to package.
the latest released gavl was 1.1.2 (2010-02-24), and this is already in
squeeze, so all dependencies should be available.

but you probably mean to modify the debian/control to reflect the
dependency (i only noticed this when i was halfway through the above
paragraph and i didn't want to throw it away :-))
i'll have to check to see whether i have a build machine with an older
version of libgavl installed to see whether this dependency really is there.
otoh, i guess it's just safe to push the /required version.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3636 bytes
Desc: S/MIME Cryptographic Signature
URL: <>

More information about the pkg-multimedia-maintainers mailing list