Bug#566924: vlc-nox: Please lower Depends: libavc1394-0, libraw1394-11

Reinhard Tartler siretart at tauware.de
Tue Feb 2 09:05:25 UTC 2010

On Di, Feb 02, 2010 at 09:41:55 (CET), Florian Schlichting wrote:

> On Sun, Jan 31, 2010 at 09:45:35PM +0100, Christophe Mutricy wrote:
>> Le Mon 25 Jan 10 à 22:39 +0100, Florian Schlichting a écrit :
>> > is it really necessary that vlc-nox *Depends:* on libavc1394-0 and
>> > libraw1394-11? My laptop doesn't even have a firewire port,
>> The slightly good news is that due to the modular nature of vlc if you
>> remove libavc1394-0 and libraw1394-11 forcefully you won't break vlc
>> (you should keep libdvbpsi however . It's needed to play MPEG2 TS files)
> Oh I thought that's exactly the situation where one could
> differentiate dependencies, and have vlc-nox only Recommends:
> libavc1394-0 and libraw1394-11 (because vlc can do without, and if
> they're just recommendend I could uninstall them without fiddling with the
> package management);

This does only work if vlc was loading those libraries at runtime. If
that is/was indeed the case, then we could do somthing similar like in
the xine-lib package ages ago.

If vlc is linked dynamically at those libs, then it would crash at
startup as ld-linux.so would fail to bootstrap the image.

xtophe, can you clarify here?

Reinhard Tartler, KeyID 945348A4

More information about the pkg-multimedia-maintainers mailing list