Bug#587486: vlc: Observe OP's dependencies

Dave Witbrodt dawitbro at sbcglobal.net
Sun Jul 4 15:47:49 UTC 2010

Package: vlc
Version: 1.1.0-1
Severity: normal

I believe that the OP is mixing unstable FFMPEG libraries with debian-multimedia libraries, and it
is having an adverse effect on vlc; see:

    Versions of packages vlc-nox depends on:
    ii  libavcodec52       5:0.6~svn20100603-0.0 library to encode decode multimedi
    ii  libavformat52      5:0.6~svn20100603-0.0 ffmpeg file format library
    ii  libavutil49        4:0.5.2-1             ffmpeg utility library
    ii  libpostproc51      5:0.6~svn20100603-0.0 postproc shared libraries
    ii  libswscale0        5:0.6~svn20100603-0.0 ffmpeg video scaling library

FWIW, I have d-m.org FFMPEG libs installed as well (not mixed), and it breaks this version of vlc.
Somehow, downgrading to 1.0.6-1 still works.

As an experiment, I tried a local build of 1.1.0-1 against the appropriate headers for the libs
installed on my system.  It failed to build because the Debian sources are modified to use
xulrunner-1.9.1, but I have 1.9.2 installed.  After unpatching 'debian/patches/502...' the build
succeeded, but vlc cannot use Xv or X11 output.  Only GLX output works, but there is stuttering
which makes playback unacceptable.

BTW, this bug (if not closed because of the unsupported libs) really needs a better subject line!

Dave W.

More information about the pkg-multimedia-maintainers mailing list