Bug#587110: Mixxx 1.7.2

Simon McVittie smcv at debian.org
Wed Nov 3 13:30:44 UTC 2010

tags 587110 + patch

On Wed, 20 Oct 2010 at 14:55:12 +0200, Sean M. Pappalardo - D.J. Pegasus wrote:
> I just tested building the following revisions of Mixxx's 1.7 code
> branch using the default settings (just running scons with no
> flags):
> 2539 (the one used for the Debian package I think)
> 2534
> 1.7.2 tarball from the Mixxx web site

It turns out the problem was that as well as the scons build system,
Mixxx 1.7.2 contains the remains of an older qmake build system. Newer versions
of debhelper try to run that as well, but because it hasn't been updated
for current Mixxx, the build fails.

Here's a branch of the Debian packaging that avoids running qmake:


I'll do a non-maintainer upload of that in a while if necessary.

> I do want to mention as well that if you are going to stick with
> 1.7.x in Squeeze that it's highly recommended that you download the
> latest code from the branch since a number of things were fixed
> since 1.7.2 but never formally released since 1.8.0 supersedes it
> (and includes applicable fixes.) Details here:
> https://code.launchpad.net/~mixxxdevelopers/mixxx/release-1.6.2

Many of these look either specific to non-Linux platforms or not tremendously
important. At this point in the Debian release process, the release team are
only accepting fixes for release-critical bugs (roughly, those that make the
package completely useless or cause data loss); are there any fixes there that
are particularly important to have?

    Debian QA

More information about the pkg-multimedia-maintainers mailing list