Bits from the Debian Multimedia Team [RELOADED]

Alessio Treglia alessio at
Thu Apr 7 11:19:45 UTC 2011

Hi all,

On Sun, Jan 30, 2011 at 11:36 AM, Jaromír Mikeš <mira.mikes at> wrote:
> Is already known what new will rev4 brings and what should be done for
> smooth transition?

what an horrible delay! I've forgotten to give an answer at all, I'm
sorry Jaromír.
However, lv2core is in unstable now and few things need to be kept in
mind while working on a package providing LV2 extensions (and *not*
only plugins!):

 - Build-depend on lv2core >= 4.0-4~
   Note that /usr/include/lv2.h was left for backward compatibility,
we'll remove it once it is not needed anymore.
 - Bundles must be installed in /usr/lib/lv2.
 - Add Provides: lv2-extension
 - Don't install headers in /usr/include and let lv2config [1] do the job.
   + When using debhelper, Insert dh_lv2config after dh_install.
      Who uses DH-7 short-form it is sufficient to pass «lv2config» to
dh's `--with`:

           dh @$ --with lv2config

Please allow me to be repetitive: the above policy *does* apply to LV2
extensions only, here is the procedure to handle packages which
provide LV2 plugins:

 - Build-depend on lv2core >= 4.0-4~ for plugins which comply to LV2 rev-4.
   It's enough to build-depend on lv2core in other cases.
 - Bundles must be installed in /usr/lib/lv2.
 - Add Provides: lv2-plugin

Updates will be notified on [2].


[1] $ man 1 dh_lv2config; man 1 lv2config

Alessio Treglia          |
Debian Developer         | alessio at
Ubuntu Core Developer    | quadrispro at
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

More information about the pkg-multimedia-maintainers mailing list