Bug#597160: cmus: volume set to 100%

Johannes Weißl jargon at molb.org
Thu Feb 10 17:03:42 UTC 2011

Hello Jonas,

On Sat, Sep 18, 2010 at 01:35:53AM +0200, Jonas Pfenninger wrote:
> > Do I understand correctly that cmus sets the volume of system-wide
> > mixer to 100% on both startup and shutdown?
> I will try to be elaborate: I'm using pavucontrol now to set the volume.
> There are two bars in pavucontrol, one for master volume and one for cmus
> volume (this one appears only when cmus is running and a song was played).
> I set both bars to some middle value. I exit cmus and start it again. Now cmus shows
> volume 100% however master volume is still on 50%. Now I play a song and I
> can see how master volume in pavucontrol is also being set to 100%. I'm pretty
> sure that cmus-volume was set to 100% during the last exit of cmus, because
> I can hear it go up very briefly before the program exits.
> summary: cmus-volume goes up on exit, master goes up on first playing of a
> song.
> Also, I realize now that the behaviour of the two bars is not influenced 
> by the setting softvol. Only the value of the software controlled volume is
> saved, but the two bars in pavucontrol go up just as without softvol.

The bug has been fixed in cmus v2.3.4 [1].

[1] http://cmus.sourceforge.net/#download

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-multimedia-maintainers/attachments/20110210/e0a55efe/attachment-0001.pgp>

More information about the pkg-multimedia-maintainers mailing list