Bug#615140: libsoundtouch-dev: needs to provide libsoundtouch1-dev

Julien Cristau jcristau at debian.org
Sat Feb 26 00:38:39 UTC 2011

Package: libsoundtouch-dev
Version: 1.5.0-3
Severity: serious
Justification: i said so

Apparently you decided to start a SONAME transition with no coordination
with the release team.  This will clash with the ongoing transition to
ffmpeg 0.6, and delay things by that much.  Please don't do this again.

Now that's out of the way...

You also renamed your -dev package from libsoundtouch1-dev to
libsoundtouch-dev, which means every reverse dependency not only needs
to be rebuilt, but needs sourceful changes.  Unless the API is
completely different from the old version, that's not acceptable.
Please add 'Provides: libsoundtouch1-dev' to libsoundtouch-dev so we can
rebuild reverse dependencies.


More information about the pkg-multimedia-maintainers mailing list