Bug#666756: Toonloop compiled with -Werror and new clutter causes warnings

Sjoerd Simons sjoerd at debian.org
Sun Apr 1 15:01:22 UTC 2012

Package: toonloop
Severity: normal
Tags: patch


It seems toonloop compiles it releases with -Werror (bad, don't). When
testbuilding with clutter 1.10 there are several warnings because of
deprecations causing the compile to fail.

Toonloop compiles properly with new clutter when warning aren't treated as
errors. Example patch attached

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dont-use-werror.patch
Type: text/x-diff
Size: 413 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-multimedia-maintainers/attachments/20120401/f2e4b00e/attachment-0001.patch>

More information about the pkg-multimedia-maintainers mailing list