Bug#663450: rosegarden: Rosegarden should recommend wavpack

John O'Hagan johnmohagan at gmail.com
Sun Mar 11 12:37:46 UTC 2012

Package: rosegarden
Version: 1:11.11.42-1
Severity: normal

Dear Maintainer,

Recording audio using Rosegarden crashes the program as the audio preview is
generated if wavpack is not installed. The audio was successfully recorded in
the ~/rosegarden folder. I tried to open it with a new instance of Rosegarden
and got an error message about needing wavpack to do so. I installed wavepack
and audio recording works normally.

As, for example, jackd is needed for audio recording in Rosegarden and is
listed as a recommend, I think wavpack should also be a recommend.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.4-2012-03-01-18.01 (PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages rosegarden depends on:
ii  flac                              1.2.1-6
ii  libasound2                        1.0.25-2
ii  libc6                             2.13-27
ii  libfftw3-3                        3.3-1
ii  libgcc1                           1:4.6.3-1
ii  libjack-jackd2-0 [libjack-0.116]  1.9.8~dfsg.1-1
ii  liblircclient0                    0.9.0~pre1-1
ii  liblo7                            0.26~repack-7
ii  liblrdf0                          0.4.0-5
ii  libqt4-network                    4:4.7.4-2
ii  libqt4-xml                        4:4.7.4-2
ii  libqtcore4                        4:4.7.4-2
ii  libqtgui4                         4:4.7.4-2
ii  libsamplerate0                    0.1.8-3
ii  libsndfile1                       1.0.25-4
ii  libstdc++6                        4.6.3-1
ii  libx11-6                          2:1.4.4-4
ii  libxml-twig-perl                  1:3.39-1
ii  sndfile-programs                  1.0.25-4
ii  zlib1g                            1:1.2.6.dfsg-2

Versions of packages rosegarden recommends:
ii  chromium [www-browser]       17.0.963.78~r125577-1
ii  csladspa [ladspa-plugin]     1:5.14.2~dfsg-2
ii  cups-bsd [lpr]               1.5.2-5
ii  epdfview [pdf-viewer]        0.1.8-1+b1
ii  evince-gtk [pdf-viewer]      3.2.1-1
ii  ghostscript                  9.05~dfsg-2
ii  iceweasel [www-browser]      10.0.2-1
ii  jackd                        5
ii  lilypond                     2.14.2-2+b1
ii  swh-plugins [ladspa-plugin]  0.4.15+1-6
ii  w3m [www-browser]            0.5.3-5

Versions of packages rosegarden suggests:
ii  qjackctl  0.3.8-1

-- no debconf information

More information about the pkg-multimedia-maintainers mailing list