Bug#673914: mplayer: -ao pulse fails even though pulseaudio is running

Jonathan Lane jonathan.w.lane at gmail.com
Tue May 22 01:14:53 UTC 2012

Package: mplayer
Version: 2:1.0~rc4.dfsg1+svn34540-1+b2
Severity: normal

Dear Maintainer,

MPlayer doesn't work with -ao pulse on my system.  I've tried killing
the pulseaudio daemon and letting mplayer try to invoke it, I've tried
explicitly starting the pulseaudio daemon right before launching
mplayer, and it still doesn't work.  This is a problem because
everything else on my desktop works with pulseaudio, so I have to stop
everything else and kill pulseaudio to free up ALSA for -ao alsa.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages mplayer depends on:
ii  libaa1                    1.4p5-39
ii  libasound2                1.0.25-3
ii  libavcodec53              7:0.10.3-dmo1
ii  libavformat53             7:0.10.3-dmo1
ii  libavutil51               7:0.10.3-dmo1
ii  libbluray1                1:0.2.2-1
ii  libc6                     2.13-32
ii  libcaca0                  0.99.beta18-1
ii  libcdparanoia0            3.10.2+debian-10.1
ii  libdca0                   0.0.5-5
ii  libdirectfb-1.2-9
ii  libdvdnav4                4.2.0-1
ii  libdvdread4               4.2.0-1
ii  libenca0                  1.13-4
ii  libesd0                   0.2.41-10+b1
ii  libfaad2                  2.7-8
ii  libfontconfig1            2.9.0-5
ii  libfreetype6              2.4.9-1
ii  libfribidi0               0.19.2-3
ii  libgcc1                   1:4.7.0-8
ii  libgif4                   4.1.6-9.1
ii  libgl1-mesa-glx [libgl1]  7.11.2-1
ii  libjack0 [libjack-0.116]  1:0.121.3+20120418git75e3e20b-1
ii  libjpeg8                  8d-1
ii  liblircclient0            0.9.0~pre1-1
ii  liblzo2-2                 2.06-1
ii  libmp3lame0               1:3.99.5-dmo1
ii  libmpeg2-4                0.5.1-3
ii  libncurses5               5.9-7
ii  libogg0                   1.3.0-1
ii  libopenal1                1:1.14-2
ii  libpng12-0                1.2.49-1
ii  libpostproc52             7:0.10.3-dmo1
ii  libpulse0                 1.1-3.2
ii  libsdl1.2debian           1.2.15-3
ii  libsmbclient              2:3.6.5-3
ii  libspeex1                 1.2~rc1-3.1
ii  libstdc++6                4.7.0-8
ii  libsvga1                  1:1.4.3-33
ii  libswscale2               7:0.10.3-dmo1
ii  libtheora0                1.1.1+dfsg.1-3.1
ii  libtinfo5                 5.9-7
ii  libvdpau1                 0.4.1-5
ii  libx11-6                  2:
ii  libx264-123               2:0.123.2189+git35cf912-1
ii  libxext6                  2:1.3.1-2
ii  libxinerama1              2:1.1.2-1
ii  libxv1                    2:1.0.7-1
ii  libxvidcore4              3:1.3.2-0.6
ii  libxvmc1                  2:1.0.7-1
ii  libxxf86dga1              2:1.1.3-1
ii  libxxf86vm1               1:1.1.2-1
ii  zlib1g                    1:1.2.7.dfsg-7

mplayer recommends no packages.

Versions of packages mplayer suggests:
ii  bzip2              1.0.6-1
ii  fontconfig         2.9.0-5
ii  mplayer-doc        <none>
ii  netselect | fping  <none>
ii  ttf-freefont       20100919-1

-- no debconf information

More information about the pkg-multimedia-maintainers mailing list