[debian-mysql] Bug#440658: mysql-server-5.0: Unable to set back the old_passwords option

Sebastien Koechlin seb.debianpkg at koocotte.org
Mon Sep 3 14:11:20 UTC 2007

Package: mysql-server-5.0
Version: 5.0.32-7etch1
Severity: normal

First configured without the old_passwords option, during upgrade from
sarge. After install, a binary is not working (static link against old mysql
lib). Reading README.Debian.gz, I run dpkg-reconfigure mysql-server-5.0 to
change the old_passwords option but this question is not asked. I can not
set the old_passwords option.

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (990, 'stable'), (100, 'oldstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=fr_FR at euro, LC_CTYPE=fr_FR at euro (charmap=ISO-8859-15)

Versions of packages mysql-server-5.0 depends on:
ii  adduser                3.102             Add and remove users and groups
ii  debconf [debconf-2.0]  1.5.11            Debian configuration management sy
ii  libc6                  2.3.6.ds1-13etch2 GNU C Library: Shared libraries
ii  libdbi-perl            1.53-1            Perl5 database interface by Tim Bu
ii  libgcc1                1:4.1.1-21        GCC support library
ii  libmysqlclient15off    5.0.32-7etch1     mysql database client library
ii  libncurses5            5.5-5             Shared libraries for terminal hand
ii  libreadline5           5.2-2             GNU readline and history libraries
ii  libstdc++6             4.1.1-21          The GNU Standard C++ Library v3
ii  libwrap0               7.6.dbs-13        Wietse Venema's TCP wrappers libra
ii  lsb-base               3.1-23.2etch1     Linux Standard Base 3.1 init scrip
ii  mysql-client-5.0       5.0.32-7etch1     mysql database client binaries
ii  mysql-common           5.0.32-7etch1     mysql database common files (e.g. 
ii  passwd                 1:      change and administer password and
ii  perl                   5.8.8-7           Larry Wall's Practical Extraction 
ii  psmisc                 22.3-1            Utilities that use the proc filesy
ii  zlib1g                 1:1.2.3-13        compression library - runtime

Versions of packages mysql-server-5.0 recommends:
ii  mailx            1:8.1.2-0.20050715cvs-1 A simple mail user agent

-- debconf information:
  mysql-server-5.0/really_downgrade: false
  mysql-server-5.0/start_on_boot: true
* mysql-server-5.0/nis_warning:
  mysql-server-5.0/postrm_remove_databases: false
* mysql-server-5.0/need_sarge_compat: false
  mysql-server-5.0/need_sarge_compat_done: true

More information about the pkg-mysql-maint mailing list