[debian-mysql] Bug#512623: This bug should not affect Lenny since it was fixed upstream in 5.0.42

Lennart Sorensen lsorense at csclub.uwaterloo.ca
Thu Feb 5 15:25:37 UTC 2009

This problem was that yassl in mysql called cpuid without first checking
that it was allowed to do that.  It was fixed in a patch (which I helped
get done) in april 2007 and included in mysql as of 5.0.42.

This bug is even listed in a README in the existing etch package.  See
libmysqlclient15off.README.Debian at the top.  The patch that fixes the
problem is in that bug report near the end.

So since Lenny appears to have 5.0.51 the bug should be gone.  I can try
to remember to test that version on my 486 but I expect it should work.

Fixing it in etch would be as simple as applying the patch from
upstream and rebuilding it, while fixing it in Lenny is already done.

Len Sorensen

More information about the pkg-mysql-maint mailing list