[debian-mysql] Bug#511929: mysql-server-5.0: missing quotes in mysql_secure_installation

Johannes Stezenbach js at sig21.net
Thu Jan 15 17:47:09 UTC 2009

Package: mysql-server-5.0
Version: 5.0.75-1
Severity: normal
Tags: patch

The mysql_secure_installation fails when the mysql root
password contains characters which need quoting (like !$%&#).

--- /usr/bin/mysql_secure_installation	2008-12-22 14:15:59.000000000 +0100
+++ mysql_secure_installation	2009-01-15 18:38:24.000000000 +0100
@@ -47,7 +47,7 @@
     echo "# mysql_secure_installation config file" >$config
     echo "[mysql]" >>$config
     echo "user=root" >>$config
-    echo "password=$rootpass" >>$config
+    echo "password='$rootpass'" >>$config
 get_root_password() {

-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.28 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=C, LC_CTYPE=de_DE.utf-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages mysql-server-5.0 depends on:
ii  adduser                3.110             add and remove users and groups
ii  debconf [debconf-2.0]  1.5.24            Debian configuration management sy
ii  libc6                  2.7-18            GNU C Library: Shared libraries
ii  libdbi-perl            1.607-1           Perl5 database interface by Tim Bu
ii  libgcc1                1:4.3.2-2         GCC support library
ii  libmysqlclient15off    5.0.75-1          MySQL database client library
ii  libncurses5            5.7+20090110-1    shared libraries for terminal hand
ii  libreadline5           5.2-3             GNU readline and history libraries
ii  libstdc++6             4.3.2-2           The GNU Standard C++ Library v3
ii  libwrap0               7.6.q-16          Wietse Venema's TCP wrappers libra
ii  lsb-base               3.2-20            Linux Standard Base 3.2 init scrip
ii  mysql-client-5.0       5.0.75-1          MySQL database client binaries
ii  mysql-common           5.0.75-1          MySQL database common files
ii  passwd                 1:4.1.1-6         change and administer password and
ii  perl                   5.10.0-19         Larry Wall's Practical Extraction 
ii  psmisc                 22.6-1            Utilities that use the proc filesy
ii  zlib1g                 1: compression library - runtime

Versions of packages mysql-server-5.0 recommends:
ii  bsd-mailx [mailx]  8.1.2-0.20081101cvs-2 A simple mail user agent
pn  libhtml-template-p <none>                (no description available)

Versions of packages mysql-server-5.0 suggests:
pn  tinyca                        <none>     (no description available)

-- debconf information excluded

More information about the pkg-mysql-maint mailing list