[Pkg-nagios-devel] Bug#574591: nagios-plugins-standard: Wrong dependencies for nagios-plugin-standard version 1.4.14-2

Glennie Vignarajah glennie at glennie.fr
Fri Mar 19 08:43:19 UTC 2010

Package: nagios-plugins-standard
Version: 1.4.14-2
Severity: important

 The new version(1.4.14-2) of nagios-plugins-standard depends on
 postfix, sendmail-bin, exim4-daemon-heavy or exim4-daemon-light. But
 there are MTA like (nullmailer, courier-mta or ssmtp ; i'm using nullmailer).
 Thus, the upgrade removes nullmailer and installs postfix.
 Please make the package depend on the virtual package
 mail-transport-agent instead of hard coded MTA packages.
 By the way, as the upgrade breaks my setup, the severity is set
 'important'. Please, downgrade it if necessary!
-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.33-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=ISO-8859-15) (ignored: LC_ALL set to fr_FR at euro)
Shell: /bin/sh linked to /bin/bash

Versions of packages nagios-plugins-standard depends on:
ii  bind9-host [host]     1:9.7.0.dfsg.1-1   Version of 'host' bundled with BIN
ii  dnsutils              1:9.7.0.dfsg.1-1   Clients provided with BIND
ii  fping                 2.4b2-to-ipv6-16.1 sends ICMP ECHO_REQUEST packets to
ii  libc6                 2.10.2-6           Embedded GNU C Library: Shared lib
ii  libldap-2.4-2         2.4.17-2.1         OpenLDAP libraries
ii  libmysqlclient16      5.1.44-3           MySQL database client library
ii  libnet-snmp-perl      5.2.0-3            Script SNMP connections
ii  libpq5                8.4.2-2+b1         PostgreSQL C client library
ii  libradiusclient-ng2   0.5.6-1            Enhanced RADIUS client library
ii  nagios-plugins-basic  1.4.14-1           Plugins for the nagios network mon
ii  radiusclient1         0.3.2-13           /bin/login replacement which uses 
ii  smbclient             2:3.4.7~dfsg-1     command-line SMB/CIFS clients for 
ii  snmp          SNMP (Simple Network Management Pr
ii  ucf                   3.0025             Update Configuration File: preserv
ii  zlib1g                1:   compression library - runtime

Versions of packages nagios-plugins-standard recommends:
ii  qstat                         2.11-1     Command-line tool for querying qua

Versions of packages nagios-plugins-standard suggests:
pn  nagios3                       <none>     (no description available)
ii  whois                         5.0.1      an intelligent whois client

-- no debconf information

More information about the Pkg-nagios-devel mailing list