[Pkg-net-snmp-devel] Bug#558488: collectd_4.8.1-2(ia64/unstable): FTBFS: -fstack-protector not supported

Julien Cristau jcristau at debian.org
Sun Nov 29 14:59:37 UTC 2009

On Sun, Nov 29, 2009 at 15:32:00 +0100, Sebastian Harl wrote:

> collectd uses net-snmp-config(1)'s --cflags option to determine the
> flags used to build the snmp plugin. net-snmp-config(1) is a shell
> script included in the Arch: all package libsnmp-base. That script is
> created at net-snmp build time and includes the CFLAGS that are used to
> build net-snmp itself (and which are then returned by 'net-snmp-config
> --cflags'). Now, net-snmp's CFLAGS include the output of 'perl
> -MExtUtils::Embed -e ccopts' (which is required for the embedded perl
> stuff), which, in turn, includes '-fstack-protector' on *some*
> architectures (presumably, on those that support that flag).
I'm pretty sure exporting random cflags used to build net-snmp to other
packages is wrong.  So moving the script to an arch:any package would
work, but so would fixing it to only include the needed flags, not
whatever net-snmp was built with.


More information about the Pkg-net-snmp-devel mailing list