[Pkg-net-snmp-devel] Bug#561124: This bug breaks existing user created scripts

Bjørn Mork bjorn at mork.no
Thu Jan 14 19:58:31 UTC 2010

severity 561124 grave

Justification: renders package mostly unusable

I'm currently pulling a few packages from testing and/or unstable into a
stable system to get some new features.  One of these is lldpd, which
now depends on libsnmp15 (>=  Seeing that this could be
pulled without any larger dependency problem, I decided to install it.

I was really surprised to see that it is actually deliberately broken
and has been so for a month, even allowing it to enter testing. 
Please try to run e.g. 

  perl -MSNMP -e 'new SNMP::Session()'

on a system with no MIBs and see the generated noise.  Never mind that
the change breaks any script the users may have created with symbolic
OID names. 

Can we please agree that this currently is in no way suitable for
release?  The change should never have made it into testing without
snmp-mibs-downloader being available.  Too late for that, but let's
ensure that it won't be in a Debian release.  Hence this message.


More information about the Pkg-net-snmp-devel mailing list