[pkg-nvidia-devel] nvidia-glx dependency on xserver-xorg-core > 1.4?

Joel Johnson mrjoel at lixil.net
Thu Feb 21 04:06:07 UTC 2008

I'm curious as to the reasoning for having a dependency on xserver-xorg-core
> 1.4 for the nvidia-glx package. What is the rationale for this?

I haven't found any reference from NVIDIA that server 1.4 is required, nor
does their installer doesn't complain when installing on lower versions. I'm
running etch, but moving to the 2.6.24. The etch nvidia-kernel-source (8776)
driver doesn't build against the newer kernels so I've done a simple
pbuilder backport of the nvidia-graphics-drivers and made nvidia-glx not
depend on a particular xserver-xorg-core and things still work.

Is there some issue that I haven't run into yet, or is the dependency on 1.4
overly restrictive?


More information about the Pkg-nvidia-devel mailing list