Bug#603878: nvidia-graphics-drivers: various issues upgrading from lenny's nvidia-*-legacy-96xx

Russ Allbery rra at debian.org
Thu Nov 18 02:44:41 UTC 2010

reassign 603878 nvidia-graphics-drivers-legacy-96xx
found 603878 nvidia-graphics-drivers-legacy-96xx/96.43.07-2
fixed 603878 nvidia-graphics-drivers-legacy-96xx/96.43.18-1
close 603878

Michael Gilbert <michael.s.gilbert at gmail.com> writes:

> package: nvidia-graphics-drivers
> version: 195.36.24-4
> severity: grave

> After the call for upgrade testing, I just did a lenny-to-squeeze
> test on an old system of mine. The nvidia-*-legacy-96xx kernel module
> and glx were installed under lenny (to support an old nvidia card that
> none of the newer nvidia drivers support). I followed the upgrade
> instructions exactly at [0].

> During the dist-upgrade (section 4.5.6), a lot of xorg drivers and xorg
> itself ended up getting removed.

Right, the problem that had is because the version of
nvidia-graphics-drivers-legacy-96xx which works properly with the squeeze
Xorg server still hasn't migrated to squeeze.  The upgrade should work
fine with the version in unstable.

Reassigning this bug and updating the version information accordingly,
since this bug is fixed in unstable.  We're just waiting on ia32-libs for
the NVIDIA packages to all migrate to squeeze.

Russ Allbery (rra at debian.org)               <http://www.eyrie.org/~eagle/>

More information about the pkg-nvidia-devel mailing list