[Pkg-ofed-devel] Why is debhelper (>= 7.0) required
Goswin von Brederlow
goswin-v-b at web.de
Tue Mar 31 21:09:44 UTC 2009
Guy Coates <gmpc at sanger.ac.uk> writes:
> Goswin von Brederlow wrote:
>> I'm wondering why most of the ofed packages require debhelper (>=
>> 7.0). I need backports for etch and that means backporting dpkg,
>> debhelper, man-db and maybe more. Is 7.0 really needed or is that just
>> there because stable has it?
> It is there because dh_make automatically put it there when I created the
> packages. I think you can back the version down without any problems. You will
> need to edit debian/compat too.
> AFAIK, the only other thing that you might need to change is the ./configure
> line in the rules file for the ofa-kernel-source package; some of the modules
> may not build correctly against the 2.6.18 kernel. (I have not tested with the
> etch 2.6.24 kernel, but I suspect you will have better luck with that.)
> You will also need to grab the libibverbs, librdmacm1, libmthca1, libmlx4-1 and
> libcxgb3-1 packages from lenny too.
We have the reverse problem. Out kernel is too new and the old libs
don't work with that.
More information about the Pkg-ofed-devel