[Pkg-openldap-devel] Bug#378832: limits directive is not working in slapd.conf

Alexander Samad alex at samad.com.au
Wed Jul 19 08:25:11 UTC 2006

Package: slapd
Version: 2.3.24-1
Severity: important


I have tried using 

limits users size=1000

but when I try to ldapsearch I get an error 4 size limit.

when I change it to 

sizelimit 1000

and retry the ldapsearch it works.  I don't want to open up the limits
to every on


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing'), (250, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/dash
Kernel: Linux 2.6.16-1-amd64-k8-smp
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=ANSI_X3.4-1968) (ignored: LC_ALL set to C)

Versions of packages slapd depends on:
ii  coreutils [fileutils]   5.96-3           The GNU core utilities
ii  debconf [debconf-2.0]   1.5.2            Debian configuration management sy
ii  libc6                   2.3.6-15         GNU C Library: Shared libraries
ii  libdb4.2                4.2.52-23.1      Berkeley v4.2 Database Libraries [
ii  libiodbc2               3.52.4-3         iODBC Driver Manager
ii  libldap-2.3-0           2.3.24-1         OpenLDAP libraries
ii  libltdl3                1.5.22-4         A system independent dlopen wrappe
ii  libperl5.8              5.8.8-4          Shared Perl library
ii  libsasl2                2.1.19.dfsg1-0.2 Authentication abstraction library
ii  libslp1                 1.2.1-5          OpenSLP libraries
ii  libssl0.9.8             0.9.8b-2         SSL shared libraries
ii  libwrap0                7.6.dbs-9        Wietse Venema's TCP wrappers libra
ii  perl [libmime-base64-pe 5.8.8-4          Larry Wall's Practical Extraction 
ii  psmisc                  22.2-1           Utilities that use the proc filesy

Versions of packages slapd recommends:
ii  db4.2-util              4.2.52-23.1      Berkeley v4.2 Database Utilities
ii  libsasl2-modules        2.1.19.dfsg1-0.2 Pluggable Authentication Modules f

-- debconf information:
  slapd/fix_directory: true
* shared/organization: a samad
  slapd/backend: BDB
* slapd/allow_ldap_v2: false
  slapd/no_configuration: false
  slapd/move_old_database: true
  slapd/suffix_change: false
  slapd/dump_database_destdir: /var/backups/slapd-VERSION
  slapd/autoconf_modules: true
* slapd/domain: samad.com.au
  slapd/invalid_config: true
  slapd/dump_database: when needed
  slapd/migrate_ldbm_to_bdb: false
  slapd/purge_database: false

More information about the Pkg-openldap-devel mailing list