[Pkg-openldap-devel] Bug#508561: Bug#508561: SIGSEGV in slapd if smbk5pwd build and installed with heimdal >= 1.0

Andrey Volkov avolkov at varma-el.com
Fri Dec 12 21:24:43 UTC 2008

Steve Langasek wrote:
> On Fri, Dec 12, 2008 at 08:47:02PM +0300, Andrey Volkov wrote:
>>> That sounds like an upstream bug.
>> Agree.
>>> The Debian packages don't build the smb5kpwd module.
>> But many people _use_ it. And, as I wrote before, I'm not sure that
>> installing module from _official_ source tree should kill slapd.
> It kills slapd because the module itself is broken.  That's not something
> the Debian maintainers are going to spend time fixing, for an issue that
> only affects code we don't ship in the binary packages.

Steve, sorry if I didn't wrote clearly before: I don't require to fix 
this module immediately. My opinion is that it will be sufficient if 
this module will not kill slapd (as minimum on debian/ubuntu) when 
someone update ldap from binaries.

So my suggestion is to put this (modified) patch to debian/patch and add 
something like "smbk5pwd is unstable in current openldap" in

Andrey Volkov

More information about the Pkg-openldap-devel mailing list