[Pkg-openldap-devel] Bug#482170: log level 'packet' stops slapd from starting

Joost De Cock joost at decock.org
Wed May 21 08:30:14 UTC 2008

Package: slapd
Version: 2.3.30-5+etch1
Severity: normal

The slapd.conf man files explains that log levels can be set in slapd.conf in various ways.
One way is to list the names of the different levels eg. 'conns' or 'args'.

When specifying 'packet' as log level, slapd fails to start, and loudly complains that log level 'packet' is not known.
Note that specifying the log level via its integer value (2) does work.

I'm not sure whether the man file is incorrect (and packet is not a correct log level name) or it's an issue in slapd.
Whatever the root cause, adjusting the log level after having RTFM shouln't cause slapd to stop functioning.

To reproduce this issue, alter yout slapd.conf to have the following log level:

loglevel      packet

And restart slapd.

Here's whay my syslog says:

May 21 10:26:56 sketch slapd[16595]: @(#) $OpenLDAP: slapd 2.3.30 (Apr  5 2008 12:05:19) $ ^Ibuildd at excelsior:/build/buildd/openldap2.3-2.3.30/debian/build/servers/slapd
May 21 10:26:57 sketch slapd[16595]: /etc/ldap/slapd.conf: line 25: <loglevel> unknown level "packet"
May 21 10:26:57 sketch slapd[16595]: slapd stopped.

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-xen
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages slapd depends on:
ii  adduser                3.102             Add and remove users and groups
ii  coreutils              5.97-5.3          The GNU core utilities
ii  debconf [debconf-2.0]  1.5.11etch1       Debian configuration management sy
ii  libc6                  2.3.6.ds1-13etch5 GNU C Library: Shared libraries
ii  libdb4.2               4.2.52+dfsg-2     Berkeley v4.2 Database Libraries [
ii  libiodbc2              3.52.4-5          iODBC Driver Manager
ii  libldap-2.3-0          2.3.30-5+etch1    OpenLDAP libraries
ii  libltdl3               1.5.22-4          A system independent dlopen wrappe
ii  libperl5.8             5.8.8-7etch3      Shared Perl library
ii  libsasl2-2             2.1.22.dfsg1-8    Authentication abstraction library
ii  libslp1                1.2.1-6.2         OpenSLP libraries
ii  libssl0.9.8            0.9.8c-4etch3     SSL shared libraries
ii  libwrap0               7.6.dbs-13        Wietse Venema's TCP wrappers libra
ii  perl [libmime-base64-p 5.8.8-7etch3      Larry Wall's Practical Extraction 
ii  psmisc                 22.3-1            Utilities that use the proc filesy

Versions of packages slapd recommends:
ii  libsasl2-modules          2.1.22.dfsg1-8 Pluggable Authentication Modules f

-- debconf information:
  slapd/allow_ldap_v2: false
  slapd/fix_directory: true
  slapd/invalid_config: true
  shared/organization: nodomain
  slapd/no_configuration: false
  slapd/migrate_ldbm_to_bdb: true
  slapd/move_old_database: true
  slapd/suffix_change: false
  slapd/dump_database_destdir: /var/backups/slapd-VERSION
  slapd/autoconf_modules: true
  slapd/purge_database: false
  slapd/domain: nodomain
  slapd/backend: BDB
  slapd/dump_database: when needed

More information about the Pkg-openldap-devel mailing list