[Pkg-openldap-devel] Bug#593550: Bug#593550: A fix

Quanah Gibson-Mount quanah at zimbra.com
Thu Aug 19 20:55:55 UTC 2010

--On August 19, 2010 10:41:51 PM +0200 Michael Rasmussen <mir at datanom.net> 

> On Thu, 19 Aug 2010 09:19:55 -0700
> Quanah Gibson-Mount <quanah at zimbra.com> wrote:
>> What version was being migrated from (i.e., what version of BDB was
>> openldap linked against?).  If it was prior to BDB 4.8, then you have to
>> do a slapcat/slapadd of the database (I assume that's already being
>> done), but before that, it is critical to completely checkpoint the
>> database via db_recover (one of the steps taken above).
> I think this is the key question. Apparently the db-tools cannot handle
> a migration from <= 4.7 to 4.8 in which case the only reliable way to
> do this is slapcat/slapadd.

Correct, it is never possible to use db-tools to upgrade OpenLDAP Databases 
across BDB versions.  The only method is slapcat/slapadd.  I'd also note 
that BDB 4.8 versions prior to 4.8.30 are not reliable and should be 
avoided (Not sure what's in debian atm).


Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration

More information about the Pkg-openldap-devel mailing list