[Pkg-openldap-devel] Bug#641165: fails to configure if it cannot start slapd

Wakko Warner wakko at animx.eu.org
Sat Sep 10 22:58:50 UTC 2011

Package: slapd
Version: 2.4.25-3
Severity: normal

I install slapd and answered no to the initial configuration and the package
failes to configure with the following:

  Omitting slapd configuration as requested.
No configuration file was found for slapd at /etc/ldap/slapd.conf. (warning).
invoke-rc.d: initscript slapd, action "start" failed.
dpkg: error processing slapd (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.33
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages slapd depends on:
ii  adduser                   3.99           Add and remove users and groups
ii  coreutils                 5.97-5.2       The GNU core utilities
ii  debconf [debconf-2.0]     1.5.19         Debian configuration management sy
ii  libc6                     2.13-20        Embedded GNU C Library: Shared lib
ii  libdb4.8                  4.8.30-9       Berkeley v4.8 Database Libraries [
ii  libdb5.1                  5.1.25-11      Berkeley v5.1 Database Libraries [
ii  libgcrypt11               1.4.6-5        LGPL Crypto library - runtime libr
ii  libgnutls26               2.12.10-1      GNU TLS library - runtime library
ii  libldap-2.4-2             2.4.25-3       OpenLDAP libraries
ii  libltdl7                  2.4-4          A system independent dlopen wrappe
ii  libperl5.12               5.12.4-4       shared Perl library
ii  libsasl2-2                2.1.22.dfsg1-8 Authentication abstraction library
ii  libslp1                   1.0.11-7       OpenSLP libraries
ii  libwrap0                  7.6.q-16       Wietse Venema's TCP wrappers libra
ii  lsb-base                  3.2-20         Linux Standard Base 3.2 init scrip
ii  multiarch-support         2.13-20        Transitional package to ensure mul
ii  perl [libmime-base64-perl 5.12.4-4       Larry Wall's Practical Extraction 
ii  psmisc                    21.5-1         Utilities that use the proc filesy
ii  unixodbc                  2.2.14p2-3     Basic ODBC tools

Versions of packages slapd recommends:
pn  libsasl2-modules              <none>     (no description available)

-- debconf information:
  slapd/backend: HDB
  slapd/allow_ldap_v2: false
* slapd/no_configuration: true
  slapd/move_old_database: true
  slapd/dump_database_destdir: /var/backups/slapd-VERSION
  slapd/invalid_config: true
  slapd/dump_database: when needed
  slapd/purge_database: false

More information about the Pkg-openldap-devel mailing list