[Pkg-openldap-devel] Bug#651700: Bug#651700: Bug#651700: slapd: BDB library version mismatch

Russ Allbery rra at debian.org
Thu Jan 5 01:46:14 UTC 2012

Steve Langasek <vorlon at debian.org> writes:

> Under the circumstances that seems a perfectly reasonable behavior for
> upstream to implement, but in Debian we hold libraries to a higher
> standard.  If the library *does* change its ABI, the package name in
> Debian will change even if upstream fails to handle this, so the check
> within OpenLDAP is redundant; and in cases where Oracle releases a
> patchlevel release that doesn't change the ABI, this actively works
> against the packaging system.

Note that ABI in this context has to encompass the on-disk format as well,
which I suspect Steve meant but which is worth saying explicitly, since my
guess would be that's where OpenLDAP ran into problems in the past that
caused this check to be added.

Russ Allbery (rra at debian.org)               <http://www.eyrie.org/~eagle/>

More information about the Pkg-openldap-devel mailing list