[Pkg-openmpi-maintainers] Bug#626164: Bug#626164: Needs to be built with --with-sge

Mark Hymers mhy at debian.org
Mon Oct 31 17:54:33 UTC 2011

On Fri, 02, Sep, 2011 at 04:57:10PM +0200, Manuel Prinz spoke thus..
> Thanks for testing and confirming! I'm reworking the packaging. This
> should be finished soon and we will build a package for SGE support.


This is a regression from lenny (openmpi 1.3 seems to have defaulted to
building SGE support whereas 1.4 defaults to not doing it... sigh) and,
wearing my SGE maintainer hat, I'd be interested in trying to get it
fixed in a point release if possible.

I've rebuilt the squeeze packages with the one line fix of adding
--with-sge to the configure call and the only difference is in

mark at squeeze:~$ debdiff libopenmpi1.3_1.4.2-4_amd64.deb libopenmpi1.3_1.4.2-4ynicsqueeze1_amd64.deb 
[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second .deb but not in first
-rw-r--r--  root/root /usr/lib/openmpi/lib/openmpi/mca_ras_gridengine.so

Control files: lines which differ (wdiff format)
Installed-Size: [-4064-] {+4020+}
Version: [-1.4.2-4-] {+1.4.2-4ynicsqueeze1+}

i.e. it doesn't change Depends or anything else.

The patch I used at work follows, I'd obviously change the version number for a
point release upload:

diff -Nru openmpi-1.4.2/debian/changelog openmpi-1.4.2/debian/changelog
--- openmpi-1.4.2/debian/changelog	2011-10-31 17:53:24.000000000 +0000
+++ openmpi-1.4.2/debian/changelog	2011-10-31 17:53:25.000000000 +0000
@@ -1,3 +1,9 @@
+openmpi (1.4.2-4ynicsqueeze1) squeeze-devel; urgency=low
+  * Rebuild with SGE support.
+ -- Mark Hymers <mark.hymers at ynic.york.ac.uk>  Mon, 31 Oct 2011 17:10:37 +0000
 openmpi (1.4.2-4) unstable; urgency=low
   * Added patch to remove use of AS_VAR_GET. Closes: #592892.
diff -Nru openmpi-1.4.2/debian/rules openmpi-1.4.2/debian/rules
--- openmpi-1.4.2/debian/rules	2011-10-31 17:53:24.000000000 +0000
+++ openmpi-1.4.2/debian/rules	2011-10-31 17:53:25.000000000 +0000
@@ -57,6 +57,7 @@
 			--includedir=\$${prefix}/lib/openmpi/include	\
 			--with-devel-headers \
 			--enable-heterogeneous \
+			--with-sge \
 # Thread support disabled because it's broken, see bug #435581

Do you (the maintainers) have any objection to me asking the SRMs if they'll
take the patch into p-u?



Mark Hymers <mhy at debian dot org>

"I once absent-mindedly ordered Three Mile Island dressing in a restaurant
 and, with great presence of mind, they brought Thousand Island Dressing and
 a bottle of chili sauce."
     Terry Pratchett, alt.fan.pratchett

More information about the Pkg-openmpi-maintainers mailing list