[Pkg-openssl-devel] Bug#330867: libssl0.9.7 g series break pam_pgsql

Krisztian PIFKO monsta at monsta.hu
Fri Sep 30 07:52:32 UTC 2005

Package: libssl0.9.7
Version: 0.9.7g-2
Severity: grave
Justification: renders package unusable

libpam_pgsql breaks after upgrading to libssl g from libssl e.

the reason (from auth log):
PAM unable to dlopen(/lib/security/pam_pgsql.so)
PAM [dlerror: /usr/lib/i686/cmov/libssl.so.0.9.7: undefined symbol: HMAC_CTX_set_flags]
PAM adding faulty module: /lib/security/pam_pgsql.so

downgrading to libssl0.9.7_0.9.7e solves the problem.

libpam_pgsql version: 0.5.2-9

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.9-ck3-skas3-v8-rc1-bs7-nudi.3
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages libssl0.9.7 depends on:
ii  debconf [debconf-2.0]         1.4.58     Debian configuration management sy
ii  libc6                         2.3.5-6    GNU C Library: Shared libraries an

libssl0.9.7 recommends no packages.

-- debconf information excluded

More information about the Pkg-openssl-devel mailing list