[Pkg-openssl-devel] Bug#203285: openssl: should guess subarchitecture and make symlinks for best arch supported

Kurt Roeckx kurt at roeckx.be
Sun May 14 00:36:33 UTC 2006


Atleast on i386, the linker will pick the right library depending on the
processor you're using.

For instance:
$ ldd /usr/bin/openssl
        libssl.so.0.9.7 => /usr/lib/i686/cmov/libssl.so.0.9.7
        libcrypto.so.0.9.7 => /usr/lib/i686/cmov/libcrypto.so.0.9.7
        libdl.so.2 => /lib/tls/libdl.so.2 (0xb7e4f000)
        libc.so.6 => /lib/tls/libc.so.6 (0xb7d1a000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0xb7f92000)

I didn't check sparc yet, currently don't have my ssh keys here, but can
check later.

So, if you don't have a problem with this, I'd like to close this bug.


More information about the Pkg-openssl-devel mailing list