[Pkg-parrot-devel] Rakudo runtime depends on parrot-devel

Allison Randal allison at parrot.org
Sat Jul 30 17:03:20 UTC 2011

On 07/29/2011 10:30 AM, Dominique Dumont wrote:
> Hello Allison
> On Friday 29 July 2011 02:28:27 Allison Randal wrote:
>> Which specific Perl libraries do you need at runtime? Most of those are
>> build tools.
> Hmm, I don't really understand your question in this context. 
> This thread is also about removing rakudo dependency on parrot-devel, which we 
> mailed about yesterday.

Yes, the reason rakudo depends on parrot-devel at runtime is because it
needs some files that are in parrot-devel and not in the main parrot
binary package. So the question is exactly which files you need.

Digging into it a bit, I suspect it'll boil down to needing NQP and PCT.
Since these libraries are only used by some language runtimes on Parrot,
it probably makes the most sense to split them into separate packages,
so parrot-devel can depend on them, and you can depend on them without
pulling in the whole of parrot-devel.


More information about the Pkg-parrot-devel mailing list