[Pkg-parrot-devel] Rakudo runtime depends on parrot-devel (was: Parrot 3.3.0 is in the archive)

Alessandro Ghedini al3xbio at gmail.com
Fri May 6 14:32:36 UTC 2011

On Thu, May 05, 2011 at 04:57:04PM +0200, Alessandro Ghedini wrote:
> Also, I noticed that currently the package runtime depends on parrot-devel,
> which is IMHO wrong (it should depends on just parrot). This is caused by
> the fact that some files needed by the compiler are shipped in the -devel
> package. I'm not sure this is a real issue in the parrot packaging (I can 
> be wrong) but it might be worth disccussing it. Any thoughts?

CCing pkg-parrot-devel.

Basically what I want to do is to have the rakudo package Build-Depends
on parrot-devel, and Depends on just parrot, which is, if I understand it
correctly, the whole reason to have a -devel package.

The files that rakudo (and probably more compilers) needs at runtime are 
those under /usr/lib/parrot/X.Y.Z/library/. Would it be possible to move 
them from the parrot-devel package to the parrot package, or am I missing 


perl -E'$_=q;$/= @{[@_]};and s;\S+;<inidehG ordnasselA>;eg;say~~reverse'

More information about the Pkg-parrot-devel mailing list