Bug#452426: Apache::MVC: require Apache::Request..

Al Nikolov alnikolov at narod.ru
Thu Nov 22 19:51:37 UTC 2007

Package: libapache2-mod-perl2
Version: 2.0.2-2.4
Severity: grave
Tags: patch
Justification: renders package unusable

Apache::MVC requires wrong class names: Apache::Request.. instead of Apache2::Request..

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable'), (200, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-5-686
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)

Versions of packages libapache2-mod-perl2 depends on:
ii  apache2. 2.2.3-4+etch1                   Next generation, scalable, extenda
ii  libapr1  1.2.7-8.2                       The Apache Portable Runtime Librar
ii  libaprut 1.2.7+dfsg-2                    The Apache Portable Runtime Utilit
ii  libc6    2.3.6.ds1-13etch2               GNU C Library: Shared libraries
ii  libdevel 2.03-3                          Perl module for inspecting perl's 
ii  libperl5 5.8.8-7etch1                    Shared Perl library
ii  liburi-p 1.35-2                          Manipulates and accesses URI strin
ii  libuuid1 1.39+1.40-WIP-2006.11.14+dfsg-2 universally unique id library
ii  libwww-p 5.805-1                         WWW client/server library for Perl
ii  netbase  4.29                            Basic TCP/IP networking system
ii  perl [li 5.8.8-7etch1                    Larry Wall's Practical Extraction 
ii  perl-bas 5.8.8-7etch1                    The Pathologically Eclectic Rubbis

libapache2-mod-perl2 recommends no packages.

-- no debconf information

*** /tmp/MVC.diff
--- /tmp/MVC.pm	2007-11-22 22:32:50.836537120 +0300
+++ /usr/share/perl5/Apache/MVC.pm	2007-11-22 22:33:40.000000000 +0300
@@ -13,9 +13,9 @@
 if (APACHE2) {
     require Apache2;
-    require Apache::RequestIO;
-    require Apache::RequestRec;
-    require Apache::RequestUtil;
+    require Apache2::RequestIO;
+    require Apache2::RequestRec;
+    require Apache2::RequestUtil;
     require APR::URI;
 else { require Apache }

More information about the pkg-perl-maintainers mailing list