Bug#508910: libapache2-mod-perl2: Cannot be used with apache2-mpm-itk

Jérémy Bobbio lunar at debian.org
Tue Dec 16 16:15:32 UTC 2008

Package: libapache2-mod-perl2
Version: 2.0.4-4
Severity: normal


When using apache2-mpm-itk instead of one of the official
apache2-mpm-{worker,event,prefork}, libapache2-mod-perl2 is not
installable due to the dependency on the apache2 package.

My tests with the attached patch have shown that except for the Debian
package dependencies, there is no problems in using mod_perl2 with
mpm-itk, at least by using the PerlSections.

This change might also be simple enough to be eligible for inclusion in

Jérémy Bobbio                        .''`. 
lunar at debian.org                    : :Ⓐ  :  # apt-get install anarchism
                                    `. `'` 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: libapache2-mod-perl2_2.0.4-4_add_mpm_itk_support.diff
Type: text/x-diff
Size: 615 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/pkg-perl-maintainers/attachments/20081216/0522ce15/attachment.diff 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-perl-maintainers/attachments/20081216/0522ce15/attachment.pgp 

More information about the pkg-perl-maintainers mailing list