Bug#480256: libversion-perl: uninstallable, depends on perl (<< 5.9.0) and perlapi-5.8.8

Damyan Ivanov dmn at debian.org
Fri May 9 11:34:34 UTC 2008

reassign 480256 perl-modules
notfound 480256 1:0.7400-2
found 480256 5.10.0-3
severity 480256 important

-=| Giacomo Mulas, Fri, May 09, 2008 at 07:59:30AM +0200 |=-
> Package: libversion-perl
> Version: 1:0.7400-2
> Severity: normal
> The transition to perl 5.10 made libversion-perl uninstallable, due to
> dependencies which cannot be satisfied on sid. Please rebuild/port to the
> new perl release.

version.pm is part of perl-modules and there is an unfortunate bug in
the Conflicts:

Package: perl-modules
Version: 5.10.0-10
Replaces: libversion-perl
Provides: libversion-perl
Conflicts: libversion-perl (<< 1:0.7400-2)

That should be << 1:0.7400-3 as we have -2 already in the archive. Or
even better, <<1:0.7401, as the version of perl-modules-provided
version.pm is 0.7400

Reassigning to perl-modules and bumping the urgency to important as this
affects upgrades from Etch.

Giacomo, you can safely remove libversion-perl when upgrading perl to

See also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460915
"perl-modules: Please Provides/Replaces/Conflicts libversion-perl"

dam            JabberID: dam at jabber.minus273.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-perl-maintainers/attachments/20080509/c3aadab6/attachment.pgp 

More information about the pkg-perl-maintainers mailing list