Bug#498885: perl: should provide libsys-syslog-perl

Niko Tyni ntyni at debian.org
Sun Sep 14 06:01:12 UTC 2008

Package: perl
Version: 5.10.0-13
Severity: normal

There's a separate libsys-syslog-perl package in the archive (version 0.26), 
overriding the Sys::Syslog module in the perl package (version 0.22).

The only reverse dependencies are:

Package: liblogger-syslog-perl
Depends: libsys-syslog-perl

Package: mailscanner
Depends: libsys-syslog-perl (>= 0.18)

Package: policyd-weight
Recommends: libsys-syslog-perl

Package: ps-watcher
Recommends: libsys-syslog-perl

Package: spamassassin
Recommends: libsys-syslog-perl

Package: postgrey
Conflicts: libsys-syslog-perl (<< 0.21)

so nobody seems to actually require the newer version for anything.
Adding a Provides: entry in perl and fixing the versioned dependency in
mailscanner would even enable removal of the separate package.

There's an annoying bug in 0.19..0.24 that should be fixed in the
core version, though. See #498776.

More information about the pkg-perl-maintainers mailing list