Bug#542016: libextutils-cbuilder-perl: new upstream release, version numbering

Damyan Ivanov dmn at debian.org
Mon Aug 17 11:02:54 UTC 2009

-=| Niko Tyni, Mon, Aug 17, 2009 at 01:41:27PM +0300 |=-
> Package: libextutils-cbuilder-perl
> Version: 0.26-1
> Severity: wishlist
> There's ExtUtils-CBuilder 0.2603 on CPAN, and Perl 5.10.1 RC1 bundles
> 0.2602.  I'm unsure what to put on the perl-modules conflict list for
> 5.10.1; saying
>  Conflicts: libextutils-cbuilder-perl (<< 0.2602)
> will force the separate package to pick up the four digit scheme
> too. I suppose the alternative would be 0.26.02.

I think the current practice is to follow 4-digit scheme when upstream 
uses it and later use version mangling (and cursing) when they are 
back to a 2-digit one, so your plan looks OK to me.

> I'll be using 0.2602 for upcoming RC1 packages targetted for
> experimental, let me know if you have better suggestions.
> In any case, this package should be updated or it will be obsoleted
> when 5.10.1 gets in sid.

True. And currently this is not bad, as the changes between 2602 and 
2603 are (thanks, jawnsy):
 + Fix INSTALLDIRS setting for older Perls (RT#47895)
 + Fix to a test file
 + Fixes for VM
i.e. not relevant to Debian so it appears we don't need the separate 
package once the core package is upgraded.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 835 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-perl-maintainers/attachments/20090817/8fe997d0/attachment.pgp>

More information about the pkg-perl-maintainers mailing list