Bug#515594: /usr/share/perl5/Exception/Class.pm: [Lenny] requires Devel::StackTrace 1.20, but Lenny does have 1.1902
ntyni at debian.org
Mon Feb 16 11:56:30 UTC 2009
On Mon, Feb 16, 2009 at 12:41:07PM +0100, Ansgar Burchardt wrote:
> Package: libexception-class-perl
> Version: 1.26-1
> Severity: grave
> File: /usr/share/perl5/Exception/Class.pm
> Tags: lenny
> Justification: renders package unusable
> Line 192 in /usr/share/perl5/Exception/Class.pm has
> use Devel::StackTrace 1.20;
> but Lenny only includes version 1.1902. This makes any code using
> Exception::Class fail:
> % perl -e "use Exception::Class"
> Devel::StackTrace version 1.2 required--this is only version 1.1902 at
> /usr/share/perl5/Exception/Class.pm line 192.
I think the packages on your system are somehow broken.
Lenny released with 1.24-1, not 1.26-1, and the libdevel-stacktrace-perl
dependencies in both of those look correct to me.
Niko Tyni ntyni at debian.org
More information about the pkg-perl-maintainers