Bug#517361: libnetaddr-ip-perl: Use of uninitialized value $NetAddr::IP::Util::n2d_format in sprintf ...

Brent Clark brentgclarklist at gmail.com
Fri Feb 27 09:27:19 UTC 2009

Package: libnetaddr-ip-perl
Version: 4.024+dfsg-1
Severity: minor

When used with spamassassin, I get this in my syslog :

Feb 27 11:24:35 mail spamd[16173]: Use of uninitialized value $NetAddr::IP::Util::n2d_format in sprintf at ../../blib/lib/NetAddr/IP/Util.pm (autosplit into ../../blib/lib/auto/NetAddr/IP/Util/ipv6_n2d.al) line 356, <GEN1757> line 153.

-- System Information:
Debian Release: 5.0
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=en_ZA.UTF-8, LC_CTYPE=en_ZA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libnetaddr-ip-perl depends on:
ii  libc6                         2.7-18     GNU C Library: Shared libraries
ii  perl                          5.10.0-19  Larry Wall's Practical Extraction 
ii  perl-base [perlapi-5.10.0]    5.10.0-19  minimal Perl system

libnetaddr-ip-perl recommends no packages.

libnetaddr-ip-perl suggests no packages.

-- no debconf information

More information about the pkg-perl-maintainers mailing list