Bug#527695: libsane-perl: FTBFS: Sane.xs:372: error: 'SANE_CAP_ALWAYS_SETTABLE' undeclared (first use in this function)

Jeffrey Ratcliffe jeffrey.ratcliffe at gmail.com
Fri May 8 20:29:28 UTC 2009

2009/5/8 Niko Tyni <ntyni at debian.org>:
> sane-backends 1.0.20 removed SANE_CAP_ALWAYS_SETTABLE, because "is _not_ part of the current
> stable API."

The really frustrating part about this is that when I wrote the
bindings, I deliberately started with SANE 1.0.19, and not what was in
HEAD. I expected, therefore, to have to add things, but never to have
to remove them unless there was a API change.

The next question is whether SANE_CAP_ALWAYS_SETTABLE is actually used
by any of the backends in 1.0.19. If not, then I can just remove it
from libsane-perl. Otherwise, I've got to go for the #ifdefs.

I guess that for sid, though, they can just be removed, as sid is
never going to see 1.0.19 again.

I'll ask on sane-devel.



More information about the pkg-perl-maintainers mailing list