Bug#555909: libxml-libxslt-perl: Fails to run against XML::LibXML 1.70 from unstable

Mikhail Gusarov dottedmag at dottedmag.net
Thu Nov 12 15:13:39 UTC 2009

Package: libxml-libxslt-perl
Version: 1.68-3
Severity: grave
Justification: renders package unusable

$ perl -e 'use XML::LibXSLT;'        
This version of XML::LibXSLT requires XML::LibXML 1.67 (ABI 1), which is incompatible with currently installed XML::LibXML 1.70 (ABI 2). Please upgrade XML::LibXSLT, XML::LibXML, or both! at /usr/lib/perl5/XML/LibXML.pm line 49.
BEGIN failed--compilation aborted at /usr/lib/perl5/XML/LibXSLT.pm line 7.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

Should work fine with next release of XML::LibXML from CPAN.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (750, 'testing'), (700, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.31-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libxml-libxslt-perl depends on:
ii  libc6                       2.10.1-5     GNU C Library: Shared libraries
ii  libxml-libxml-perl          1.70.ds-1    Perl interface to the libxml2 libr
ii  libxml2                     2.7.6.dfsg-1 GNOME XML library
ii  libxslt1.1                  1.1.26-1     XSLT processing library - runtime 
ii  perl                        5.10.1-5     Larry Wall's Practical Extraction 
ii  perl-base [perlapi-5.10.1]  5.10.1-5     minimal Perl system

libxml-libxslt-perl recommends no packages.

libxml-libxslt-perl suggests no packages.

-- no debconf information

More information about the pkg-perl-maintainers mailing list