Bug#577209: libdbi-perl: DBI<>DBD ABI change breaks partial upgrades

gregor herrmann gregoa at debian.org
Fri Apr 16 18:56:23 UTC 2010

On Tue, 13 Apr 2010 23:19:30 +0300, Niko Tyni wrote:

> So I propose the following updated plan (supported by Gregor and Damyan):

Looks like we actually have to implement the plan now :)
> B1. reupload DBI-1.609 as libdbi-perl 1.610.90+is+1.609-1 that
>     Provides: perl-dbdabi-94

No, not uploaded, just prepared in svn.

Niko, Dam, @others: could you please take a look and
fix/uploaded/tell me to upload?

> B2. binNMU libdbd-*-perl [1] again with a dep-wait on the new libdbi-perl;
>     wait until the currently broken binNMUs in squeeze are superseded

Niko, could you please handle this binNMU request, I think you can
explain the situation best :)
> B3. file bugs to get a binNMU safe perl-dbdabi-N dependency into
>     libdbd-*-perl, N==94 at this point

I'm happy to update the packages in the pkg-perl repo and prepare
patches for the others.

 .''`.   http://info.comodo.priv.at/ -- GPG key IDs: 0x8649AA06, 0x00F3CFE4
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT & SPI, fellow of Free Software Foundation Europe
   `-    NP: Paul McCartney & Wings: Ballrooom Dancing
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-perl-maintainers/attachments/20100416/75934efd/attachment.pgp>

More information about the pkg-perl-maintainers mailing list