Bug#636793: libobject-insideout-perl: FTBFS with perl 5.14: needs alternate dependency on perl 5.14 to satisfy libthreads-shared-perl

Dominic Hargreaves dom at earth.li
Fri Aug 5 22:24:00 UTC 2011

Source: libobject-insideout-perl
Version: 3.81-1
Severity: important
User: debian-perl at lists.debian.org
Usertags: perl-5.14-transition

This package cannot be built with perl 5.14, since perl 5.14 provides
and breaks libthreads-shared-perl, and this package has a versioned
Build-Dep on libthreads-shared-perl (>= 1.33).

The solution is to add an alternative dependency on perl 5.14:

libthreads-shared-perl (>= 1.33) | perl (>= 5.14)

This package also has a run-time dependency on libthreads-shared-perl
so the same change should be made there too.

Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

More information about the pkg-perl-maintainers mailing list