Bug#636952: libapache-db-perl: uses Devel::DProf, deprecated in perl 5.14

Dominic Hargreaves dom at earth.li
Sun Aug 7 11:51:43 UTC 2011

Package: libapache-db-perl
Version: 0.14-2
Severity: normal
User: debian-perl at lists.debian.org
Usertags: perl-5.14-transition

This package uses Devel::DProf which was deprecated in perl 5.14 and
is expected to be removed from perl 5.16:

./libapache-db-perl-0.14/lib/Apache/DProf.pm:    require Devel::DProf;

libdevel-dprof-perl is provided by perl >= 5.12.3-7.

Therefore, please add a Depends on the separately packaged

libdevel-dprof-perl | perl (<< 5.12.3-7)

(Alternatively, consider whether this package should be removed instead).

This should probably also be forwarded upstream as a bug in META.yml,
which does not declare a dependency on Devel::DProf.

Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

More information about the pkg-perl-maintainers mailing list