Bug#614410: libclass-meta-perl: uses packages deprecated in perl 5.12

Dominic Hargreaves dom at earth.li
Mon Feb 21 19:59:47 UTC 2011

Package: libclass-meta-perl
Version: 0.63-1
Severity: minor
User: debian-perl at lists.debian.org
Usertags: perl-5.12-transition perl-5.14-transition

During a rebuild of perl modules using the perl 5.12.3 packages in
experimental, the following warning was observed during the build of

Class::ISA will be removed from the Perl core distribution in the next major release. Please install the separate libclass-isa-perl package. It is being used at /build/dom-libclass-meta-perl_0.63-1-i386-dPLqup/libclass-meta-perl-0.63/blib/lib/Class/Meta.pm, line 697.

This warning will become a fatal error with perl 5.14.
Please depend/build-depend as appropriate on

libclass-isa-perl | perl (<< 5.10.1-13)

Note that perl (>= 5.10.1-13, << 5.12.0) Provides: libclass-isa-perl,
so the above is a no-op on squeeze and current sid.


Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

More information about the pkg-perl-maintainers mailing list