Bug#608849: libdata-formvalidator-perl: DateCalc should be a recommends not a full dependency

Nicholas Bamber nicholas at periapt.co.uk
Tue Jan 4 00:14:23 UTC 2011

Package: libdata-formvalidator-perl
Version: 4.66-1
Severity: wishlist

This package includes a module
Data::FormValidator::Constraints::Dates which is not the most
important module in the package.
There is now an alternative
Data::FormValidator::Constraints::DateTime which is in the process of being
packaged for Debian.
DFC::Dates is based upon DateCalc which some consider to be inferior to
DateTime, the basis of DFC::DateTime.

-- System Information:
Debian Release: 6.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libdata-formvalidator-perl depends on:
ii  libdate-calc-perl           6.0-2        Perl library for accessing dates
ii  libemail-valid-perl         0.184-1      Perl module for checking the valid
ii  libfile-mmagic-perl         1.27-1       Perl module to guess file type
ii  libimage-size-perl          3.230-1      module for determining image sizes
ii  libmime-types-perl          1.30-1       Perl extension for determining MIM
ii  libperl6-junction-perl      1.40000-1    Perl6 style Junction operators in 
ii  libregexp-common-perl       2010010201-1 module with common regular express
ii  perl                        5.10.1-16    Larry Wall's Practical Extraction 

libdata-formvalidator-perl recommends no packages.

libdata-formvalidator-perl suggests no packages.

-- no debconf information

More information about the pkg-perl-maintainers mailing list