Bug#610197: libboolean-perl: 0.24 fatal "Modification of a read-only value attempted" error

Ivan Kohler ivan-debian at 420.am
Sun Jan 16 03:33:15 UTC 2011

Package: libboolean-perl
Version: 0.24-1
Severity: grave
Tags: upstream sid
Justification: renders package unusable

$ perl -e 'use boolean'
Modification of a read-only value attempted at /usr/share/perl5/boolean.pm line 34.
BEGIN failed--compilation aborted at /usr/share/perl5/boolean.pm line 39.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

Appears to be fixed in upstream 0.25 according to changelog.

-- System Information:
Debian Release: 6.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-vserver-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libboolean-perl depends on:
ii  perl                          5.10.1-17  Larry Wall's Practical Extraction 

libboolean-perl recommends no packages.

libboolean-perl suggests no packages.

-- no debconf information

More information about the pkg-perl-maintainers mailing list