Bug#632146: libemail-send-perl: description encourages using the module, contrary to its documentation

Damyan Ivanov dmn at debian.org
Wed Jun 29 20:51:21 UTC 2011

Package: libemail-send-perl
Version: 2.198-3
Severity: minor

Here's the first paragraph from Email::Send(3pm):

    Email::Send is going away... well, not really going away, but it's being 
    officially marked "out of favor."  It has API design problems that make it 
    hard to usefully extend and rather than try to deprecate features and 
    slowly ease in a new interface, we've released Email::Sender which fixes 
    these problems and others.  As of today, 2008-12-19, Email::Sender is 
    young, but it's fairly well-tested. Please consider using it instead for 
    any new work.

Compare this to the text in the package's long description:

    Email::Send provides a very simple, very clean, very specific interface to 
    multiple mailers. The goal of this software is to be small and simple, easy 
    to use, and easy to extend.

I think upstream's wish of phasing out the module should e reflected somehow in 
the long description.


More information about the pkg-perl-maintainers mailing list